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ABSTRACT

The developments in information technology (IT) make it possible to collect, to process and to manipulate geography information in digital forms. This method is much more efficient as compared to the analog method. The geographic information is possible to be collected directly at site by using digital photogrammetry method. The method of digital photogrammetry enable us to process photography raster to produce digital surface model (DSM), which later can be used to correct geographic information.

A case study using digital photogrammetry approach in collecting information concerning the size of buildings has been carried out in the campus of the University of Malaya. A digital map that consists of spatial data of buildings and infrastructures in the campus is produced. The spatial data are arranged in layers using the base map with the scale of 1:3000. GIS software called UM-INFO has been developed for the use in analyzing the information as well as for producing report on distribution of building spacious utilization map. Sufficient database such as numbers of floor for each block, areas of floor, numbers of student, numbers of staff etc were input to UM-INFO software. The use of building space for various purposes and other facilities in the campus are identified. Furthermore, the sizes of building space utilities are compared to the guideline by the National Economic Panning Unit of Malaysia. The study has discovered all the faculties and academic centers have at least 3% more than the nominal area except the Faculty of Art & Social Sciences (AFSSO). The AFSSO required another 50% more of the nominal area.

In conclusion, this study has proven the effectiveness of Digital Photogrammetry and Geographical Information System (GIS) in producing a map to show the distribution of space usage in higher learning institution. This research has successfully shown that the digital photogrammetry method is able to capture digital data much faster and accurately. The combination of digital photogrammetry and GIS technology has proven to be the best choice in optimizing the space usage. This technique increases productivity at low cost as well as serves as a powerful tool for planning purposes.
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1.0
INTRODUCTION  

This research evaluates the photogrammetry method in producing input data for the GIS system and the use of GIS in analyzing building space utilities. The University of Malaya was taken as a case study. The first phase covers the spatial data collection. All data are collected from various resources such as plans and maps including text data. To allow the data to be analyzed by computer, the data from the map sheet must be transformed into digital format through digitization process. The process of coordinate registration and scanning needs to be done at the map sheet before the digitization process. Thematic digital map of University of Malaya that contains spatial information such as buildings and almost all infrastructures has been arranged using the base map on the scale of 1: 3000. The coordinate registration process is done to standardize the coordinate system of the map layers. The software GIS MapInfo is used for digitizing operation. Inaccurate geometry and outdated maps are two major problems in producing a good map base. Digital Photogrammetry is used to overcome this problem. This method provides air orthophoto as additional information in GIS software. Combination between digital Photogrammetry and GIS has formed the GIS MapInfo database. Attributed information from MapInfo data to every building is combined with the data obtained from Relational Data Base Management System (RDBMS). The structure of database is restored to add more necessary information. The GIS procedures are reorganized to analyze and to gather extra information. Among the analysis that successfully be done using this method is to establish space use status based on building floor areas in every faculty.

2.0 OBJECTIVES

The main objective of this research is to develop and set up a GIS database of buildings and all infrastructures in University of Malaya. One of the applications is to analyze the building space usage at every faculty in the campus. The following aspects have been studied throughout this process,
a. Ability of the technique of digital photogrammetry in producing resources for spatial GIS data for building surfaces.

b. Development of GIS data base for buildings and infrastructures
c. Establishment of efficient database for analyzing space utilities based on GIS methodology.           

3.0 METHODOLOGY

Inaccurate spatial information is the main problem in GIS. The spatial information can be obtained from various data resources with different precision. The first phase of the research is to analyze the precision of digital photogrammetry (Digital Surface Model and orthophoto). The second phase is to analyze the efficiency of GIS software in gathering building spatial information followed by analysis of the building space utilities.
4.1 Data Process via Digital Photogrammetry Method

Digital Photogrammetry method via diapositive air-photo is used to produce digital orthophoto. A black and white diapositive air-photo with a scale of 1: 20000 that covers the entire Malaya University has been used in this research. The photo was scanned at the resolution of 300dpi and 600dpi by desktop scanner model A3 Sharp JX – 610 to produce a pair of digital diapositive. (Format TIFF with greys 256 scales). By using Desktop Mapping System (DMS) software, 12 Digital Surface Models (DSM) were produced by auto correlation method. Every model has different matrix size correlations, which are 7x7, 11x11 and 17x17.  Median Filtration 3x3 is imposed on every DSM model. The most accurate DSM model has been chosen to produce the precise orthophoto geometry. Elevation of grid point sample at the 150 m gap for every DSM model is chosen to ascertain the precision. The height of reference elevation for grid points was created using the analytical plotting equipment (PROMAP). The statistical test, variance analysis (ANOVA) is applied to generate the final precision according to the DSM models (see table 1). The finest DSM model is selected to generate the digital orthophoto. The precision of geometry orthophoto is tested using the sample points from GIS MapInfo software and later compared to the measurement from the analysis stereo model.

4.2 Building Spatial Data Extraction

Building spatial data extraction is designed using GIS MapInfo software. Digital orthophoto in DMS format is transferred into GIS MapInfo format. Orthophoto image is registered into Selangor Cassini coordinate system in MapInfo software. Enhancement image process is done to upgrade the view on the computer screen. A quality image will make it more user-friendly and easier to be digitized. Model data polygon is used in the digitization. The necessary information of the infrastructure is also extracted as well as the buildings location.

4.3 GIS Data Base Structure of Building

For spatial analysis, building spatial information must be linked with the attribute information. In MapInfo software, the attribute information is kept in the database and is systematized in tables. Building database structure contains information such as the ID, building name, building code, the storey of the building and floor area as shown in table 2.
4.4 Space Used Analysis Using GIS MapInfo Software

With GIS MapInfo, the floor areas of each block can be automatically determined by using menu Table>Update Column. Every record in the floor areas attribute is updated every time after the model is generated. The operator only needs to fill in information of the block such as the building’s ID, number of storey, building’s name etc. If the number of storey of the building is known, then the entire floor space and building area can be determined using module Table>Update Column again. To do this the attribute information about the floor area must be filled in first. The name or the code is needed to classify the building utilities. In this study, buildings are classified according to faculty. The building space area is calculated based on this information (see table 3). Building thematic map with the information of building space is then produced. The next analysis is to verify whether or not the building space in each faculty is sufficient. The nominal space is computed by multiplying the number of students and the floor space needed per student. The floor space per student is different from one course to another course that is decided by National Economic Planning Unit of Malaysia (UPEN) As a result, a table showing the maximum floor space used for every faculty is produced as shown in table 4. The calculated current space area that resulted from GIS software operation is then compared to the nominal space as shown in table 5.

4.0 ANALYSIS AND RESULT

4.1 Digital Stereo Model

Two pairs of digital stereo model from air-photo with resolution of 300 dpi and 600 dpi were produced to generate DSM. Both stereo models comprise a minimum level of 29 m and maximum level of 145 m above sea level. Both levels are stereo-measured on computer screen using anaglyph viewing. Orientation parameters for models are determined with 13 earth control points. The calculation has resulted deviation of rms (x, y) 0.33 pixels or 0.61 m above ground level for the model with resolution of 300 dpi. For the model with resolution 600 dpi, the rms (x, y) deviation was 0.68 pixel or 0.62 m above ground level. Nominal pixel resolution for model 300 dpi and 600 dpi are 1.836 m and 0.918 m above ground level respectively (see table 6a and 6b).   

4.2 Digital Surface Model (DSM)
In this study DSM has been generated and developed by auto-correlation using Desktop Mapping System (DMS). A number of 12 DSM models (DSM1 to DSM12) were produced where six of them based on 300 dpi stereo model and the other six DSM models based on 600 dpi stereo model. The size of 7x7, 11x11 and 17x17 of matrix correlation were used to generate and develop these DSM model. Median Filtration 3x3 was imposed at every DSM in order to eliminate the spike effects.

Every DSM model is created by 6000-point level at the range of 30m grids. However, only 200 points were selected from each of the DSM model. Aggregation method is used to select these points that produced 12 new DSM model with the range of 150m grids. The analysis plotting equipment (PROMAP) with high accuracy is then used to measure the height of the same grid level for comparison purpose. The results obtained from the analysis have shown; first, the accuracy of the level is increasing with respect to the higher size of the matrix correlation (see figure 1). Secondly, by applying the Median Filtration the DSM models have better level accuracy as shown in figure 2. 
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Figure 1: Accuracy of level vs the size of matrix correlation
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Figure 2: Accuracy of level before and after filtration

The consistent accuracy can be achieved when we increase the size of the correlation matrix. The analysis has proven that the level accuracy with photo resolution 600 dpi significantly better than photo resolution 300 dpi as shown in figure 3. All the analysis has resulted that the DSM12 model is the most similar to the digital surface model reference (see figure 4). Thus, this model has been selected for the generation of the orthophoto development. 
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Figure 3: Accuracy of level with photo resolution of 300 and 600 dpi
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                Figure 4: Comparison between mean digital levels via mean analyzed level (reference)

1.3 Digital Orthophoto

Figure 5 shows digital orthophoto, which was developed using the DSM12 model. This orthophoto was generated by the nearest interpolation method. Cassini Coordination system was used for orthophoto registration in GIS MapInfo software. The Standard Deviation (S.D) of the orthophoto at checking point X and Y is 4.6m and 1.8m respectively.
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Figure 5: Orthophoto of University of Malaya

1.4 Building Mapping

Building digitization of the orthophoto image that is displayed on the screen monitor is done using GIS MapInfo software. The polygon shape is used to map all the buildings in University of Malaya area. Figure 6 shows the overlaid building mapping of the orthophoto. The accuracy of the digitization is based on the map base of 1:3000 scales. The scale on the monitor must at least four times larger than 1:3000 scales during the digitization process in order to obtain better accuracy.
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Figure 6: Map of UM’s buildings, road infrastructures, and rivers

1.5 Create Building Topology 
Topology is known as “spatial relationship between geographic objects”. Most GIS software requires creating topology before the line of any object can be converted to polygon object. Mistakes such as enjoined line, over lined and suspended line must be fixed before creating topology. One of the advantages of using topology data is to prevent the repetition of digitization of similar border of polygon. Besides that, it allows the operator to use lined object only during digitization. Since MapInfo software does not use topology data model, the operator must apply polygon shape during building digitization. The operator can choose the polygon button and set a tolerance snap before proceeding to digitization. Spatial information of building and data platform will directly be connected to MapInfo system by using an identifier. The structure of the data platform has been modified to supplement the number of attribute according to the needs.
1.6 GIS Data Platform for Building

The data platform for building needs to be structured in order to restore the building attribute information. The attributes for a building are the building’s name, code, number of floors, floor area, and building’s ID. Variables of integer type are addressed to the floor’s number attribute and area attributes while variable of character type is addressed to building’s name and code attributes. 

The building information such as ID, name, code and number of floors is entered into the MapInfo data platform by using Window>New Browser Window menu in the MapInfo. Figure 7 shows some parts of the building attributes information.
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Figure 7: Relationship between attribute data and spatial data

It also showed the attributes of NamaBangunan on the right and building map on the left. Every record of NamaBangunan is related to the building map and is represented by the index box in the bangunan browser window. Figure 8 showed some parts of the building’s record that has been entered and displayed using Window>New Browser Window.
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Figure 8: Records of buildings in GIS MapInfo data platform

1.7 Calculation of Standard Space Used based on Faculty
UPEN has outlined the application of nominal space and is depending on the size of the building’s floor in local universities. The area unit of the floor space of each student is different depending on the faculty’s type which has been set by UPEN.

The equation below is used to determine the size of nominal space of a building:

Size of nominal space = Number of students x Area unit

Where;


Area unit = area (m2) / 1 student of its faculty 

.

Example:

The number of student’s enrolment in the faculty of engineering = 2500

Area Unit = 5m2
Space size = 5 x 2500 = 12500m2
1.8 Space Used Estimation by GIS MapInfo

Every building’s polygon in the MapInfo data platform consists of Standard Attributes such as area, perimeter, central coordinate, etc. However, this kind of information is not displayed directly in the table windows unless it is requested by an operator from the Query>SQL Select menu. Based on the area information, the space size of every building can be estimated. To determine the space size of the building, the information of number of floors is required. This information can be obtained by site visit. Then, this information will be entered into the building data platform. By using Query>SQL Select menu, the area of building space can be determined using the equation below:

Area of building’s space = area of building’s polygon x number of floor

4.9 The Needs of Space Used Analysis

The result in table 5 has clearly shown the building’s space used with respect to every faculty in University of Malaya. Based on the space utility required, the Sports Centre (PPSUK) has 297% more space from the nominal space and thus has the largest extra space. Meanwhile, the faculty of social science has an insufficient space of 50% less than the nominal space. According to the current space used, the Faculty of Science possesses the largest space (94415 m2) while the Faculty of Law has the smallest space size (12120m2). Therefore, it can be concluded that a faculty has the smallest free space size of 26% and largest free space size of 297% with exception for the Faculty of Social Science that possesses no extra space.

6.0
CONCLUSION

The Digital Photogrammetry method has the ability to update the spatial data more efficiently. The accuracy of digital Photogrammetry product depends on the scanned quality, earth control point, air-photo quality, air-photo resolution, DSM accuracy and algorithm in developing orthophoto. Digitalization of digital orthophoto on the monitor is easier to operate compared to stereo digital method in obtaining geographic information.

GIS software based on personal computer has the ability to do spatial analysis such as space utility analysis etc. Combination of Digital Photogrametry method and GIS system using personal computer is very effective compared to analysis method with network system or mainframe, to analyze space utilities using GIS. Other than Photogrammetry scanner with high accuracy, the non-Photogrametry scanner or A4 Desktop Publishing Scanners has high potential to shoot digital air-photo (W.M.N Wan Mohamad). However, the pre-process must be done first to clear the sway effect on the systematic scanner that produces air-photo.

Lastly, the integration of digital Photogrammetry and GIS in analyzing space used can help university management to control the space used utilities and identify the needs of a new building more efficiently. Therefore, detailed research is required to identify the causes of systematic deviation in Photogrammetry system and ways to minimize the deviation.
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APPENDIX
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           Table 1: Results and analysis at the meant level of 0.05 ANOVA using Dunnet method
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Table 2: Structure of buildings data platform
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Table 3: Space area of buildings block according to faculty
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                          Table 4: Maximum area of floors space according to its faculty

                                                              (Resource - UPEN)

[image: image12.png]Dependent Variable: Ketingoian Aras Grid DT
Dunnettt (2-sided)”

95% Confidence

o W Wean Interval
Kaedah_Digital 112/~ Kaedah_Digital_1-12/ | Diference Lower | Upper
Kaedah Analisis 88 Kaedah Analisis_08 (-)) std.Enor | sig Bound | Bound
T 55 141787 17663 000 | 92881 | 190714
2 55 1188147 17683 000 | 69898 | 167730
3 e 3i68 | 17663 [7E] awaz | 102615
7 ] 53768 | 17663 [FE] 4842 | 107675
5 55 40105 | 17663 048 28266-02 | 98116
® £ 595 | 17663 183 | 9321 | sesiz
7 55 12467 17883 000 | 62329 | 160162
8 £ 93765 | 17663 000 | 44845 | 147681
s 55 571sr | 17663 0z 8214 | 100047
0 55 45800 | 17663 080 | -3116 | 94716
T 55 44424 | 17663 057 | -4492 | 93341
2 5 9437 | 17662 224 | 14420 | 00413

*.The mean difference is significant atthe .05 level
a. Dunnetttests reat one group as a control, and compare all other groups against it





       Table 5: Current space used according to its faculty
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       Table 6a: Orientation Parameter of stereo model (300 dpi resolution)
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Table 6b: Orientation Parameter of stereo model (600 dpi resolution)
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